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Prefase
Nowadays all branches of industry, science and technology cannot exist
without computer supply. It is the most significant equipment of modern engineering.
The demands of modern enterprises claimed for the development of science
using new computer technologies.
Graphic design methods are successfully used in many fields of industry for a
long period of time.
The usage of these methods in computers with the help of automatic design
systems resulted in solving many special disciplines matters.
As a result Engineering Graphics course tought at Higher School for more than
150 years has undergone great changes too.
The course in Engineering Graphics was not only renamed into Engineering &
Computer Graphics but modern technical supply and new approaches as to their
learning were introduced.
Due to modern computer technologies and programme supply it became much
easier to represent objects in n-dimension space. Moreover the usage of these
methods in a teaching process improve the students’ thinking abilities and creative
skills, develop their space imagination and help to solve complex engineering tasks.
The following Programme sets are used for laboratory works in Engineering &
Computer Graphics course:
-OrCAD system is designed for projecting and design of principal schemes in
electronics, microelectronics and electrotechniques;
-Work Bench system is designed for design of principal electric schemes and
their workability control.
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PLOTTING ELECTRIC SCHEMES OF COMMUNICATION SYSTEMS IN
ORCAD CAPTURE
1. PERPOSE OF WORK
1.1 To learn the main OrCAD rules
1.2 To draw different electric schemes
1.3 To creat new electric element’s libraries
1.4 To acquaint with Ukrainian and foreign standarts for electric schemes
drawings

Introduction
Laboratory works data are used for mastering main rules of electric schemes
Compositions and drawings in OrCAD CAPTURE Graphical redaction as a
component part of OrCAD.

2. KEY OUTLINES
Orcad family products offer a total solution for your core design tasks:
schematic- and VHDL-based design entry; FPGA and CPLD design synthesis;
digital, analog, and mixed-signal simulation; and printed circuit board layout.
What’s more, Orcad family products are a suite of applications built around an
engineer's design flow–not just a collection of independently developed point tools.
Orcad Capture is just one element in our total solution design flow. Capture is
a versatile design entry product you can use to create schematics for analog or mixed
signal designs, printed circuit board layout designs, and programmable logic designs.
First, create your flat or hierarchical design in the schematic page editor, then use
Capture’s tools toquickly annotate it and prepare it for the next stage of development.
OrCAD program package consist of the next modules:
− OrCAD Capture (for plotting electric schemes);
− OrCAD Pspise (for modeling eclectic devises);
− OrCAD Layont (for projecting printed-component boards of
eclectic devises).
In this laboratory curse we will learn OrCAD Capture.
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To start Capture:
1. From the Start menu, point to Programs and choose Orcad Family Release.
2. From the Orcad Family Release menu item, choose Capture.
Once you start Capture, you see the Capture session frame. You do all your
schematic design and processing within this window.

Figure 1 – Capture’s session frame
The minimized Session Log icon in the lower left portion of the Capture
session frame is the session log. The session log provides information about
everything you have done in the current Capture session.
You use the project manager to collect and organize all the resources you need
for your project. These resources include schematic folders, schematic pages, part
libraries, parts, VHDL files, and output reports such as bills of materials and netlists.
Figure 2 shows a new project manager window.

Figure 2 – New project manager window
6
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To create a new design
1. From the File menu, choose New, then choose Design.
2. The design opens in a new PCB project manager and a new schematic page
displays.
The first time you save a new design, the Save As dialog box appears, giving
you the opportunity to specify a drive and replace the system-generated name.

To open an existing design
1. From the File menu, point to Open, then choose Design. The Open Design
dialog box displays.
2. Select a design (.DSN) or type the name in the File name text box, then
choose the Open button. The design opens in the project manager

To save a new design or library
1. With the design or library selected in the project manager, from the File
menu, choose Save. The Save As dialog box displays.
2. Enter a name for the design or library in the File name text box, specify a
location, then choose the Save button.
The design or library is saved, and the project manager remains open. When
you close the project, Capture prompts you to save the project file.
When the project manager window is active, you can close a project without
quitting Capture, or you can close and save your project as you quit.

To close a project
From the project manager’s File menu, choose Close Project.
When you close a project, a dialog box displays, asking if
you want to save your changes.
To quit Capture
From the project manager’s File menu, choose Exit.
When you choose the Exit command, a dialog box displays, asking if you want
to save your changes.
7
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−
−
−
−
−

Choose Yes to save the specific document within the project.
Choose Yes All to save all documents in the project.
Choose No to close the document without saving it.
Choose No All to close all open documents without saving them.
Choose Cancel to abort closing the project.

The toolbar
Capture’s toolbar is dockable (that is, you can select an area between buttons
and drag the toolbar to a new location) and resizable. By choosing a tool button, you
can quickly perform a task. If a tool button is dimmed, you can’t perform that task in
the current situation.

Figure 3 - Capture’s toolbar
Some of the tools operate only on what you have selected, while others give
you a choice of either operating on what is selected or expanding the scope to the
entire project. Table 1 summarizes the tools on the toolbar. The tasks that these tools
perform are described throughout this manual.
Table 1 – Tools on the Capture toolbar
Tool
Name
Description
Create a new document based on the active
1
New
document. Similar to the New command on
the File menu.
Open an existing project or library. Similar to
2
Open
the Open command on the File menu.
Save the active document, schematic, or part.
3
Save
Equivalent to the Save command on the File
menu.
Print the selected pages in the schematic
folder, or the active schematic page or part.
4
Print
Equivalent to the Print command on the File
menu.
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5

Cut

6

Copy

7

Paste

8

Undo

9

Redo

10

MRU

11

Zoom In

12

Zoom Out

13

Zoom Area

14

Zoom All

15

Annotate

16

Back Annotate

17

Design Rules

Remove the selected object and place it on the
Clipboard. Equivalent to the Cut command on
the Edit menu.
Copy the selected object to the Clipboard.
Equivalent to the Copy command on the Edit
menu.
Paste the contents of the Clipboard at the
cursor. Equivalent to the Paste command on
the Edit menu.
Undo the last command performed, if possible.
Equivalent to the Undo command on the Edit
menu.
Redo the last command performed, if possible.
Equivalent to the Redo command on the Edit
menu.
Place a part or symbol from the list of most
recently used parts and symbols.
Zoom in to see a closer, enlarged view.
Equivalent to choosing Zoom and In from the
View menu.
Zoom out to see more of your document.
Equivalent to choosing Zoom and Out from
the View menu.
Specify an area of the schematic page or part
to enlarge to fill the entire window. Equivalent
to choosing Zoom and Area from the View
menu.
View the entire document. Equivalent to
choosing Zoom and All from the View menu.
Assign part references to parts on the selected
schematic pages.
Equivalent to the Annotate command on the
Tools menu.
Back annotate the selected schematic pages.
Equivalent to the Back Annotate command on
the Tools menu.
Check for design rules violations on the
9
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selected schematic pages. Equivalent to the
Design Rules Check command on the Tools
menu.
Create a netlist for the selected schematic
Create Netlist pages. Equivalent to the Create Netlist
command on the Tools menu.
Create a cross reference report for the selected
Cross Reference schematic pages. Equivalent to the Cross
Reference command on the Tools menu.
Create a bill of materials report for the selected
Bill of Materials schematic pages. Equivalent to the Bill of
Materials command on the Tools menu.
Toggle schematic page and part editing to
Snap-to-Grid
either on or off grid.
Display the project manager window for the
active document, providing an overview of
Project Manager project contents. Equivalent to choosing a
project manager window by number from the
Window menu.
Open online help. Equivalent to the Help
Help Topics
Topics command on the Help menu.
Check

18

19

20
21

22

23

The tool palettes
Capture has two tool palettes: one for the schematic page editor and one for the
part editor. Both tool palettes are dockable (that is, you can click on an area between
buttons and drag a tool palette to a new location) and resizable.
While the drawing tools on the two tool palettes are identical, each tool palette
has different electrical tools. After you choose a tool (and, in the case of some tools,
after you respond to the tool’s dialog box), click the right mouse button to display a
context-sensitive pop-up menu.

The schematic page editor tool palette
The first group of tools on the tool palette is electrical tools, used to place
electrical connectivity objects. The second group is drawing tools, used to create
graphical objects without electrical connectivity.
10
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Figure 4 – Schematic page editor tool palette
Table 2 describes the tools on the schematic page editor tool palette.
Table 2 – Tools on the schematic page editor tool palette
Tool
Name
Description
1
2

3

4

5

6
7
8

9

10

Select

Select objects. This is the normal mode.
Select parts from a library for placement.
Part
Equivalent to the Part command on the Place
menu.
to draw nonDraw wires. Press and hold
orthogonal (not a multiple of 90°) wires.
Wire
Equivalent to the Wire command on the Place
menu.
Place aliases on wires and buses. Equivalent to
Net Alias
the Net Alias command on the Place menu
to draw nonDraw buses. Press
orthogonal segments. Equivalent to the Bus
Bus
command on the Place menu.
Place junctions. Equivalent to the Junction
Junction
command on the Place menu.
Draw bus entries. Equivalent to the Bus Entry
Bus Entry
command on the Place menu.
Place power symbols. Equivalent to the Power
Power
command on the Place menu.
Place ground symbols. Equivalent to the Ground
Ground
command on the Place menu.
Place hierarchical blocks. Equivalent to the
Hierarchical
Hierarchical Block command on the Place menu.
Block
Place hierarchical ports on schematic pages.
Hierarchical Port Equivalent to the Hierarchical Port command on
the Place menu.
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11

Hierarchical Pin

12

Off-Page
Connector

13

No Connect

14

Line

15

Polyline

16

Rectangle

17

Ellipse

18

Arc

19

Text

Place hierarchical pins in hierarchical blocks.
Equivalent to the Hierarchical Pin command on
the Place menu.
Place off-page connectors. Equivalent to the OffPage Connector command on the Place menu.
Place no-connect symbols on pins. Equivalent to
the No Connect command on the Place menu.
Draw lines. Equivalent to the Line command on
the Place menu.
to draw
Draw polylines. Press and hold
non-orthogonal polylines. Equivalent to the
Polyline command on the Place menu.
Draw rectangles. Holding
constrains to a
square. Equivalent to the Rectangle command on
the Place menu.
Draw ellipses. Holding
constrains shape
to a circle. Equivalent to the Ellipse command on
the Place menu.
Draw arcs. Equivalent to the Arc command on
the Place menu.
Place text. Equivalent to the Text command on
the Place menu.

The part editor tool palette
The first group of tools on the part editor tool palette are electrical tools, used
to place pins and IEEE symbols. The second group of tools are drawing tools, used to
create graphical objects without electrical connectivity.

Figure 5 – Part editor tool palette
Table 3 describes the tools unique to the part editor tool palette.
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1
2
3

Table 3 – Tools on the schematic page editor tool palette
Tool
Name
Description
Place IEEE symbols on a part. Equivalent to the
IEEE Symbol
IEEE Symbol command on the Place menu.
Place pins on a part. Equivalent to the Pin
Pin
command on the Place menu.
Place multiple pins on a part. Equivalent to the
Pin Array
Pin Array command on the Place menu..

Selecting and deselecting objects
Once you select an object, you can perform operations on it, including moving,
copying, cutting, mirroring, rotating, resizing, or editing. You can also select multiple
objects and edit them, or group them into a single object. Grouping objects maintains
the relationship among them while you move them to another location. This section
describes different ways to select individual objects and groups of objects in both the
schematic page editor and the part editor.
To select an object
Position the pointer on the object and click the left mouse button. The object
displays in the selection color.
To reset the selection color
1. From the Options menu, choose Preferences, then select the Colors tab.
2. Click the left mouse button on the Selection color.
3. Click to select a color from the Selection Color window, then click OK.
Click OK again to dismiss the Preferences dialog box.
To select multiple objects
For each object to select, position the pointer on the object and hold
while
you click the left mouse button. Every object in the selection set displays in the
selection color.
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To deselect objects
Click on the schematic page away from any objects. Selected objects become
deselected. Keep in mind that a part occupies a rectangular area encompassing all its
graphics. This means that a part may occupy a larger area than is initially apparent.
To select all objects in an area

1. From the tool palette, choose the selection tool.
2. Click on an area away from any objects or parts to deselect any items that
may be selected.
3. Move the pointer to one corner of the area to select. Press and hold the left
mouse button while you drag the mouse to the opposite corner, then release the left
mouse button. Every object in the selection set appears in the selection color.
To include or exclude objects intersected by your selection rectangle
1. From the Options menu, choose Preferences.
2. On the Select tab, select one of the Area Select options. You can choose
Intersecting to include items that are not fully enclosed by your selection rectangle, or
choose Fully enclosed to exclude items that were not entirely selected.
To select all objects on a schematic page or part
From the Edit menu, choose Select All. All objects appear in the selection
color.
To select an object from a set of objects stacked atop one another
1. Position the pointer over the stack of objects.
2. Press
while you click the left mouse button. This cycles through the
objects in the stack.
To remove one object from a selection set
Place the pointer over the object, press

, and click the left mouse button.

Grouping objects
Use the Group command on the Edit menu to group multiple objects into one
selectable object. This is a convenient way to maintain the relationship among several
14
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objects while moving them to another location. You can nest groups, meaning a
group can contain other groups as well as objects. The Group command is only
available when multiple objects are selected. Objects remain grouped until you
ungroup them or close the schematic page or part that contains them.
To group multiple selected objects
1. Select the objects you want to group. (See Selecting and deselecting objects
on page 2-26 for more information).
2. From the Edit menu, choose Group. You can move the objects as a group.
3. When have finished working with the objects as a group, you can ungroup
them. From the Edit menu, choose Ungroup.
Moving and resizing graphic objects
For some objects such as wires, buses, lines, ellipses, rectangles, and so on you
can edit the object’s size and shape by clicking on it and dragging its resize handles.
Before you can move or resize a graphic object, you must first select it. A selected
object has resize handles that you use to change the size of the graphical object.
To resize and move objects
1. Select the object to resize or move.
2. To resize the object, press the left mouse button on a resize handle, and drag
the handle until the object is the size you would like it. Release the mouse button.
or
To move the object, press the left mouse button anywhere on the object except
on a resize handle and drag the object until it is where you want it. Release the mouse
button.
3. To deselect the object, click in an area where there are no parts or objects.

Undoing, redoing, and repeating an action
You use the Undo command to undo your action. To repeat an edit action, use
the Repeat command. For example, you might move a selected object five grid units,
then realize you also need to move a different object the same distance. Select the
15
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second object, then from the Edit menu, choose the Repeat command. You can use
the Undo, Redo, and Repeat commands with the following
actions:
– Placing objects
– Deleting objects (except for the Repeat command)
– Copying objects
– Moving objects
– Resizing objects
– Rotating objects
– Mirroring objects
To undo an action
From the Edit menu, choose Undo.
To reverse an undone action
From the Edit menu, choose Redo.
To repeat a command
1 Perform the command once.
2 From the Edit menu, choose Repeat.
To repeat a copy operation
1. Select an object on a schematic page.
2. Press
and drag the object to a new location. This creates a copy of the
object. Leave the object selected.
3. From the Edit menu, choose Repeat. The pointer epeats the relative move in
step 2 and an additional object is placed.
Creating new projects, designs, libraries, and VHDL files
Capture includes a project wizard that provides an easy method for creating a
project, complete with library and simulation resources.
Creating a project does not create a design within the project. A new design
inherits characteristics from the settings in the Design Template dialog box, so you
should always check those settings before you create a design. A newly created
project contains a schematic folder that holds one schematic page. After you create a
schematic folder, you can move existing pages into it, and you can create new pages
in it.
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Engineering graphics “OrCAD Capture”

Libraries store parts, symbols, custom title blocks, as well as schematic folders
and the schematic pages contained in them. With Capture, you can have as many
libraries as you wish to suit any purpose, and you can specify the name and storage
location of your library. Each library is available to each project.
To create a new project
1. From the File menu, choose New, then choose Project. The New Project
dialog box appears.
2. Type a name for your new project in the Name text box.
3. Use the Browse button to select a new directory.
4. Select a project type in the Create a New Project Using group box, and click
OK. Capture provides the following project types:
- Analog or mixed signal circuit select this type of project if you intend to use
your design with PSpice. Follow the guidance of the Analog Mixed-Mode Project
wizard to add the appropriate files to your project.
- PC board select this type of project if you intend to use your design with
Orcad Layout. Follow the guidance of the PCB Project Wizard to add the appropriate
files to your project.
- Programmable logic select this type of project if you intend to use your
design with an FPGA or CPLD EDA tool. Follow the guidance of the Programmable
Logic Project Wizard to add the appropriate files to your project.
- Schematic select this type of project if none of the other project types apply.
Using this option, Capture creates a basic project containing only the design file.
To create a new design
1. From the File menu, choose New, then choose Design.
2. The design opens in a new PCB project manager and a new schematic page
displays.
The first time you save a new design, the Save As dialog box appears, giving
you the opportunity to specify a drive and replace the system-generated name.
To create a new schematic page
1. On the File tab of the project manager, select the schematic folder that
requires a new schematic page.
2. Click the right mouse button and choose New Page from the pop-up menu.
A new schematic page appears within the schematic folder you selected in step 1.
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To create a new library
1. From the File menu, choose New, then choose Library.
2. The library opens in the project manager and a Library Cache folder is added
to the project manager, or the library opens in the existing open project manager and
a library cache is added.
To create a new VHDL file
There are two ways to create a new VHDL file in Capture:
1. From the File menu, choose New, then choose VHDL File.
2. A VHDL file opens in Capture’s VHDL programmer’s editor.
Or
1. With the project manager active, choose New VHDL File from the Design
menu. The file opens in the VHDL programmer’s editor and a dialog box appears,
asking if you want to add the file to the project.
2. Choose the Yes button to add the file to the project that is currently open.
The Save As dialog box appears.
3. Select a directory for the file and supply a filename. By default, the VHDL
file’s name is VHDLn.VHD (where n is an integer indicating the number of .VHD
files created in the current session).
4. Choose the Save button. Capture saves the file and places it in the Design
Resources folder of your project.
Opening existing projects, designs, libraries, and VHDL files
You can open an existing project, design, library or VHDL file. Existing
schematic pages can only be opened from within designs and libraries.
To open an existing project
1. From the File menu, point to Open, then choose Project. The Open Project
dialog box displays.
2. Select a project (.OPJ) or type the name in the File name text box, then
choose the Open button. The project opens in the project manager.
To open an existing design
1. From the File menu, point to Open, then choose Design. The Open Design
dialog box displays.
2. Select a design (.DSN) or type the name in the File name text box, then
choose the Open button. The design opens in the project manager.
18
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To open an existing schematic page
1. In the project manager, select the File tab and double-click the icon of a
schematic folder; this expands the folder and reveals the schematic pages it contains.
2. Double-click on the icon of the schematic page you want to open. The
schematic page opens in a schematic page editor window

Figure 6 – Open project, design, and schematic page
To open an existing library
1. From the File menu, point to Open, then choose Library. The Open Library
dialog box displays.
2. Select a library (.OLB) or type the name in the File name text box, then
choose the Open button. The library opens in the project manager.

Figure 7 – Open library
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To open an existing VHDL file
1. From the File menu, point to Open, then choose VHDL File. The Open
VHDL File dialog box displays.
2. Select a VHDL file (.VHD) or type a name in the File name text box, then
choose the Open button. The VHDL file opens in Capture’s text editor.

Figure 8 – Open VHDL file

Working with files in a project
Using the project manager, you can add or delete project files. You can add any
file to your project, including libraries and VHDL files. Files not in ASCII format, or
a Capture generated format, may not appear as expected when opened in Capture.
To add a file to your project
1. In the project manager, select the folder to which you want to add a file.
2. From the Edit menu, choose Project. The Add File to Project Folder dialog
box displays.
3. Select the file you want to add and choose the Open button. The file is added
to the project.
Or
Drag the file from the Windows Explorer into the folder in the project
manager.
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To delete a file from a project
1. In the project manager, select the file you want to delete.
2. Press the

key. The file is removed from the project.

Saving projects, designs, and libraries
When the project manager window is active, you can save a new or existing
project, design, or library. The Save command saves all open documents referenced
by the project, as well as the project itself.
A Capture design file (.DSN) is associated with a project file (.OPJ). Each time
you use the Save As command from the File menu to save a design file to another
name or directory, you should also use Save As for the project file.
The Save As command saves files depending on what you have selected in the
project manager.
- If one or more designs or libraries are selected, Capture prompts you to save
each file in turn.
- If no top-level folders (Design Resources or Outputs) are selected, and items
other than designs or libraries are selected, the Save As command is unavailable.
- If no designs or libraries are selected in the project manager, Capture prompts
you to save the project.
To save a new design or library
1. With the design or library selected in the project manager, from the File
menu, choose Save. The Save As dialog box displays.
2. Enter a name for the design or library in the File name text box, specify a
location, then choose the Save button.
The design or library is saved, and the project manager remains open. When
you close the project, Capture prompts you to save the project file.
To save an existing project
With the Design Resources or Output folder selected, choose Save from the
File menu.
The project is saved, and remains open in the Capture session frame.
Using the Save As command
The following process saves a .DSN file and a .OPJ file into the same directory
so you can continue editing the current project without altering the original files.
21
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1. In the project manager, select the design file.
2. From the File menu, choose Save As.
3. Change the drive and directory as appropriate, then select the file name and
click Save.
4. Select the Design Resources folder.
5. From the File menu, choose Save As.
6. Change the drive and directory as appropriate, then select the file name and
click Save.
Closing a project
When the project manager window is active, you can close a project without
quitting Capture, or you can close and save your project as you quit.
To close a project
From the project manager’s File menu, choose Close Project.
When you close a project, a dialog box displays, asking if you want to save
your changes.
To quit Capture
From the project manager’s File menu, choose Exit.
When you choose the Exit command, a dialog box displays, asking if you want
to save your changes.
- Choose Yes to save the specific document within the project.
- Choose Yes All to save all documents in the project.
- Choose No to close the document without saving it.
- Choose No All to close all open documents without saving them.
- Choose Cancel to abort closing the project.
Placing, editing, and connecting parts and symbols
Capture includes libraries containing parts, power symbols, and ground
symbols. You can place instances of these objects on a schematic page. Once you
place a part, you can edit its appearance, properties, or location. Once you have
placed a power or ground symbol, you can rotate it or edit its name.
This chapter contains information about placing and editing objects from
Capture libraries. It also explains how to connect these objects using wires and buses.
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Figure 8 – Schematic with power and ground symbols
connectivity between schematic pages. You use off-page connectors to connect
signals between schematic pages within a schematic folder. You use hierarchical
blocks, hierarchical ports, and hierarchical pins to connect signals from one
schematic folder to another, or from an attached schematic folder. Wires and buses
are used to conduct signals between parts and electrical objects. Nets are made up of
one or more wires; a bus represents multiple signals or nets.
Placing and editing parts
Capture includes libraries with a total of over 30,000 parts that you can use on
your schematic pages. You can also create your own parts.
A library part has a package view, which corresponds to the actual physical
object that can be placed, for example, on a printed circuit board. The package view
identifies the physical pin numbers and the number of logical objects (for example,
parts or devices) that are contained within the package.

Figure 10 – Part editor in package view
The different parts that make up a package can be identical in their graphic
appearance and electrical connectivity (homogeneous) or they can be dissimilar in
their graphic appearance or electrical connectivity (heterogeneous).
23
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In addition to the package view, a library part has a part view, which is a
graphical representation used to define a single, logical, electrical object whose
electrical connectivity is represented by pins.

Figure 11 – Part editor in part view
Each part has a set of properties that contains information–such as part value
and reference designator–used by layout or simulation tools. In addition, you can
create your own unique part properties that hold information relevant to your
application.
Parts have pins that define the part’s electrical connectivity. Pins carry
information in properties that define the characteristics of each pin. This information
includes the pin’s name, number, shape (clock, dot, dot-clock, line, short, or zero
length), type (3-state, bidirectional, input, open collector, open emitter, output,
passive, or power), width (scalar or bus), and visibility.
The pin type is used by the Design Rules Check command on the Tools menu
to check conformance to basic electrical rules.
A primitive part is a basic part without any underlying hierarchy. A
nonprimitive part is a part that has an underlying hierarchy, such as an attached
schematic folder, PSpice model, or VHDL code. Placing a nonprimitive part adds all
its underlying hierarchy to your project without moving the actual schematic folders,
making it easy to add levels of hierarchy to your project.

Placing parts
You select parts from libraries and place them on schematic pages using the
Part command on the Place menu, or using the part tool on the schematic page editor
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tool palette. Alternatively, if you’ve placed the part or symbol recently,place the part
using the Most Recently Used (MRU) list onthe Capture toolbar.

To place a part
1. From the schematic page editor’s Place menu, choose Part.
or
Choose the part tool on the schematic page editor’s tool palette. The Place Part
dialog box appears.
2. Select a part from the list that appears.
or
In the Part text box, type the name of the part. If you aren’t sure of the name of
the part, enter wildcard characters to constrain the list of parts, then click OK.
Valid wildcard characters are an asterisk (*) to match multiple characters and a
question mark (?) to match a single character.
After you type the name of the part to be placed, click OK. All parts in the
libraries (listed in the Libraries list box) that match the part name appear in the box
below the Part text box. When you select a part from this box, its graphic image
displays in the preview box.
3. When you have located the part you want to place, click OK.
An image of the selected part is attached to your pointer. You can click the
right mouse button to display a pop-up menu with commands that you can use to
change the properties of the part before you place it. You can mirror the part
horizontally or vertically, rotate the part, or edit the part’s properties.
4. Move the pointer to the location on your schematic page where you want to
place the part, then click the left mouse button. This places an instance of the part on
your schematic page. (You can place multiple instances of the part by clicking the left
mouse button at each location where you want an instance of the part.)
5. When you are done placing instances of the selected part, choose End Mode
from the right mouse button pop-up menu, or press
.
To place a part using the Most Recently Used (MRU) List
1. While the schematic page editor is active, select a part or symbol from the
MRU list on the Capture toolbar.
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An image of the selected part is attached to your pointer. You can click the
right mouse button to display a pop-up menu with commands that you can use to
change the properties of the part before you place it. You can mirror the part
horizontally or vertically, rotate the part, or edit the part’s properties.
2. Move the pointer to the location on your schematic page where you want to
place the part, then click the left mouse button.
This places an instance of the part on your schematic page. (You can place
multiple instances of the part by clicking the left mouse button at each location where
you want an instance of the part.)
3. When you are done placing instances of the selected part, choose End Mode
from the right mouse button pop-up menu, or press
.
Place Part dialog box

Figure 12 – Place Part dialog box
Part Specifies the name of the part. Start typing the part name and if Capture
finds the part in the selected libraries, it will automatically complete the part name for
you. If you aren’t sure of the exact name of the part, you can enter wildcard
characters to constrain the list of parts, then click OK. Valid wildcard characters are
an asterisk (*) to match multiple characters and a question mark (?) to match a single
character. The names of all parts in the selected libraries that match the wildcard
appear in the Part list box.
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Part list Lists the names of all parts in the selected libraries that match the
name entered in the Part text box. If more than one library is selected, the part name
is followed by a forward slash (/) and a library name. When you select a part in the
list, its name appears in the Part text box, and its graphic displays in the preview box.
The full path of the library appears when you hover your pointer over a part or a
library name in the part list.
Libraries Lists the library names currently available. All parts in the selected
libraries that match the Part text box appear in the Part list. To select more than one
library, hold
Add Library Displays a standard Open dialog box that you can use to locate a
library and add it to the Libraries

Remove Library Removes the selected libraries from the Libraries list.
Part Search Opens the Part Search dialog box, so you can search for a part in
all the libraries listed in a particular directory. while you click the mouse. To select
all the libraries in the list, press
.
The full path of the library appears when you hover your pointer over the
library name.
Graphic You can choose the view of the part: Normal or Convert. Some parts
have a Convert view that is used for things such as a DeMorgan equivalent of a part.
Packaging Parts per package indicates the number of parts in the package you
are editing. Part indicates which part of a multiple-part package you are placing.
Preview box Displays the graphic of the selected part.
Application Indicator Four possible property values (Layout, Schematic
View, VHDL, and PSpice) cause one or more icons to appear at the bottom of the
Place Part dialog box while you place a part that has one or more of the properties. A
schematic view or VHDL implementation type property causes the Schematic View
or VHDL icon to appear, while the PSpice icon indicates that a PSpice Template
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property exists and the Layout icon shows that a PCB Footprint property is on the
part or symbol. The name of the relevant downstream tool appears when you hover
your pointer over the icon.
Most Recently Used (MRU) part list

The Most Recently Used list is in the middle of the Capture toolbar. It is
enabled only the window of a schematic page is active.
Each time you place a part or symbol using a command from the Place menu,
the name of that same part or symbol is added to the top of the MRU list. When you
select a part or symbol from the MRU list and use it in your design, the name of that
item moves to the top of the list.
The MRU list holds up to 25 placed items for a given project. If you exceed
that limit, Capture removes the last part or symbol from the list and places the name
of the most recently placed item at the top of the list.
Capture saves the MRU list on a project-by-project basis for each session. If
you have more than one project open, the list updates for the active project.
You can select a part from the MRU list using any of these methods:
- Use the mouse. Expand the MRU drop-down list by clicking on the arrow at
the right of the list, then click on a part or symbol to select it.
- Type the part or symbol name. Click in the MRU list box and begin typing
the name of the part or symbol.
Capture automatically completes the name if the item is in the list. When the
name is highlighted in the MRU list box, press
. If the part or symbol is not in
the MRU list, but is a part in the set of configured libraries, an image of the part
.

attaches to your pointer when you press
- Use the shortcut. Press
and

to highlight a part in the MRU list. Press

to select a part or symbol in the list. When the correct part or symbol is

highlighted in the list box, press

.

Searching for parts
Capture can search for a particular part inside all the libraries it finds in the
specified directory.
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To find a part
1. In the schematic page editor, choose Part from the Place menu.
2. Click the Part Search button. The Part Search dialog box appears.
3. Enter the part name you want to locate.
4. Click Browse to locate the directory where your libraries are located.
5. Click Begin Search. Capture returns the names of all the libraries in the
specified directory, that contain your part.
Editing parts
You can move a part on a schematic page by selecting it and dragging it to a
new location. You can use the Rotate or the Mirror command from the Edit menu.
You can use the part editor to change the part’s physical appearance, and you can edit
the part’s properties. When you edit a part on a schematic page, your edited part
differs from the part in the library and exists only in your design; you can place
another copy of the part you edited by using the Copy command from the Edit menu,
and by dragging the part from the design cache.
To edit the physical appearance of a part, select it, and either choose Part from
the Edit menu or choose Edit Part from the right mouse button pop-up menu. This
opens the part in a part editor window. After you finish editing the part and choose
Save, you’re given a choice of updating the single instance, or updating all instances
in the design.
If you update only the single instance, Capture creates a new part in the design
cache. If you update all instances, Capture replaces the library part in the design
cache with your edited part. These new parts are placed in the design cache with “-n”
appended to the name, where n is an integer.
To edit the properties of a part, select the part on the schematic page, and either
choose Properties from the Edit menu, or choose Edit Properties from the right mouse
button pop-up menu. You can also double-click the part.
This displays the property editor, shown in Figure 12.

Figure 13 – Property editor with filter set to Capture
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Capture displays properties according to the selected filter. All the properties
are shown when the filter is set to All. General schematic page properties are shown
when the filter is set to Capture. The following are common properties:
Value Specifies the part value name. By default, the part value is set to the
name of the part if you don’t specify a part value in the library.
Reference Specifies the part reference.
Primitive Default indicates that the part uses the setting in the Hierarchy tab of
the Design Properties dialog box. Yes indicates that the part is primitive. No indicates
that the part is nonprimitive.
Designator Indicates which part of a multiple-part package you are editing.
PCB Footprint The PCB physical package name to be included for this part in
the netlist.
Power Pins Visible Specifies the visibility of the part’s power pins.
Implementation Type Specifies if the part has an attached schematic folder or
other implementation, and the type of implementation, if one exists. Implementation
types include schematic folders, VHDL entities, netlists, and PSpice models.
Placing and editing power and ground symbols You can place power and
ground symbols, and you can edit their names before or after placing them. You can
also edit the text associated with the symbols. The name of a power symbol becomes
the name of the global net that is created.

Figure 14
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Placing power and ground symbols
Power and ground symbols are placed on a schematic page using the Power
command or Ground command on the Place menu, or using the power tool or ground
tool on the tool palette. Power and ground symbols are selected from libraries the
same way parts are selected from libraries. CAPSYM.OLB contains all the power
and ground symbols shipped with Capture.
To place a power symbol

1. From the schematic page editor’s Place menu, choose Power.
or
Choose the power tool on the schematic page editor’s tool palette.
The Place Power dialog box appears.
2. In the Symbol text box, type the name of the symbol to place. If you aren’t
sure of the exact name of the symbol, you can enter wildcard characters to constrain
the list of symbols, then press
. Valid wildcard characters are an asterisk (*) to
match multiple characters and a question mark (?) to match a single character. All
power symbols in the libraries selected in the Libraries list box that match the name
of the power symbol are listed in the box below the Power Symbol text box. When
you select a symbol from this box, its graphic image appears.
3. After you locate the power symbol you want to place, click OK. An image of
the power symbol is attached to your pointer. You can press the right mouse button to
display a pop-up menu with commands to change the attributes of the power symbol
before you place it. You can mirror the power symbol horizontally or vertically, or
rotate it.
4. Move the pointer to the location on your schematic page where you want the
power symbol and click the left mouse button. This places the power symbol on your
schematic page. You can place multiple instances of the power symbol by clicking
the left mouse button each place you want an instance of the symbol.
5. When you are done placing power symbols, choose End Mode from the right
mouse button pop-up menu, or press

.
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To place a ground symbol
Follow the instructions in the previous section but substitute the Ground
command or the ground tool in the appropriate places.
Place Power and Place Ground dialog boxes
The Place Power and Place Ground dialog boxes are identical, except that each
displays the last power or ground symbol you placed on this page. This figure shows
the Place Power dialog box.

Figure 15 – Place Power dialog box
Symbol Specifies the name of the power or ground symbol in the library. If
you aren’t sure of the exact name of the symbol, you can enter wildcard characters to
constrain the list of symbols, then click OK. Valid wildcard characters are an asterisk
(*) to match multiple characters and a question mark (?) to match a single character.
The names of all symbols in the selected libraries that match the wildcard appear in
the Symbol list box.
Symbol list Lists the names of all symbols in the selected libraries that match
the name entered in the Symbol text box. If more than one library is selected, the
symbol name is followed by a slash (/) and a library name. When you select a symbol
in this list, its name displays in the Symbol text box, and its graphic displays in the
preview box.
Libraries Lists the library names currently available. Select the libraries from
which to select power or ground symbols. All symbols in the selected libraries that
match the Symbol text box display in the Symbol list. To select more than one
library, press

while you click the mouse.
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Preview box Displays the graphic of the selected symbol.
Add Library Displays a standard Open dialog box that you can use to locate a
library and add it to the Libraries list.
Remove Library Removes the selected libraries from the Libraries list.
Name Assigns a name–such as +5, GND, +5VDC, -12 VDC, VSS, or VEE–to
the symbol. By default, the name of the symbol is assigned.
Editing power and ground symbols
You can change the name of a power or ground symbol by selecting the
symbol on the schematic page, and either choosing Properties from the Edit menu, or
choosing Edit Properties from the right mouse button pop-up menu.
You can also double-click the symbol. This displays a dialog box in which you
can edit the symbol’s name, then click OK.
You can also edit the display properties of the name of the power or ground
symbol. Select only the text of the symbol, then either choose Properties from the
Edit menu, or choose Edit Properties from the right mouse button pop-up menu. You
can also double-click the text. This displays a Display Properties dialog box. Once
you have finished editing the properties, click OK.
Placing and editing no-connect symbols
A no-connect symbol (shown as an “X” attached to a pin) causes unused pins
to be ignored by reports (such as Design Rules Check and netlists) that show
unconnected pins. If a pin is connected, the no-connect symbol doesn’t affect the pin.
They are pin properties.
Placing no-connect symbols

No-connect symbols are placed on pins on a schematic page using the No
Connect command on the Place menu, or using the no-connect tool on the schematic
page editor’s tool palette.
To place a no-connect symbol
1. From the schematic page editor’s Place menu, choose No Connect.
or
Choose the no-connect tool on the schematic page editor’s tool palette.
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2. Position the mouse over the pin end and click the left mouse button. The end
of the pin changes from a square (unconnected) to an X (not connected). This
changes the pin property called “Is No Connect” from False to True and displays an
X on the pin end.
Editing no-connect symbols
key. To remove a noNo-connect symbols cannot be deleted using the
connect symbol, place another no-connect symbol on top of the existing no-connect
symbol. You can temporarily override a no-connect symbol by attaching a wire to the
pin, but if you delete the wire, you’ll again be able to see the no-connect symbol.
Placing and connecting wires and buses
Two wires or two buses can be connected physically by the following methods:
- If you begin or end a wire segment on a segment of another wire, as in a Tintersection, Capture adds a junction and the wires are connected.
- If you begin or end a bus segment on a segment of another bus, as in a Tintersection, Capture adds a junction and the buses are connected.
- If you begin or end a wire segment on a segment of another wire, as if to
continue the same wire, Capture treats it as one wire. The same is true of two bus
segments. A wire and a bus can be connected in name only by the following methods:
- If you begin or end a wire segment on a segment of a bus, Capture adds a
junction (if they T-intersect), and they will be connected.
- If you begin or end a bus segment on a segment of a wire, Capture adds a
junction (if they T-intersect), and they will be connected.
Wires and buses, along with other parts and symbols in the project that are
logically connected via net names, form a net. When you place a wire, it is assigned a
system-generated netname, which you can replace with an alias or a different
netname. Once a bus acquires a valid name or alias, that name or alias defines the
signals carried by the bus and connects those signals to the corresponding nets. For
example, the alias A[0:3] defines a four-signal bus and connects the four signals it
carries with nets A0, A1, A2, and A3.
Like wires, buses can acquire names and aliases by two means:
- Direct application of a net alias with valid bus name
- Electrical connection to a hierarchical port, off-page connector, or global bus
pin with a valid bus name.
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Placing wires
When you connect a wire to a pin, Capture provides visual confirmation of the
connection by removing the unconnected pin box on the pin. If two continuous wires
cross at 90°, they are not electrically connected unless you create a junction by
clicking the left mouse button as you draw a wire across an existing wire.
You can determine whether wires or buses that cross each other are connected
by the presence or absence of a junction. Unless a junction is present, wires or buses
that cross each other are not connected. If you drag a net up to another net so that
they touch, Capture adds a junction where the nets meet and the two nets are
connected.
You can add a junction using the Place junction button on the schematic page
editor’s toolbar, or by choosing Junction from the Place menu in the schematic page
editor. You can place junctions anywhere on a wire or bus, but they only take effect
when another object is connected at the junction’s location. You can remove a
junction by selecting the junction and pressing
on top of the existing one.

, or by placing another junction

To place a wire
1. From the schematic page editor’s Place menu, choose Wire.
or
Choose the wire tool on the schematic page editor’s tool palette.
2. Click the left mouse button to start the wire.
3. Move the mouse to draw the wire. Click the left mouse button if you want to
place a vertex and change directions.
4. Double-click to end the wire. The wire displays in the selection color.
or
Click on another wire. Clicking on another wire connects the two wires.
5. When you are done placing wires, choose End Mode from the right mouse
button pop-up menu, or press

.

Editing wires
Capture makes it easy for you to modify the appearance and properties of a
wire. You can implement most changes with two clicks of the mouse or a key
combination.
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To create a net alias
1. Select a wire or net on the schematic page.
2. From the Place menu, choose Net Alias.
or
Click the Net Alias tool on the schematic page editor tool palette.
3. Type a name in the Alias text box and choose a color, rotation, and font for
display in the Place Net Alias dialog box.
4. Click OK to finish.
To edit a net alias
1. Double-click the alias name on the wire or net.
or
Right-click on the alias name on the wire or net and choose Edit Properties
from the pop-up menu.
or
Select the alias name, then from the Edit menu, choose Properties.
2. Change alias name, color, rotation, or font settings in the Edit Net Alias
dialog box.
3. Click OK to finish.
Moving wires
To move a wire, select it and drag it to a new location; the wire stretches to
maintain its connectivity. To break the wire’s connectivity, press A while you move
it. To move a vertex, select a wire segment next to the vertex and drag the vertex to
the new location.
Capture warns you of connectivity changes as you drag an object by placing
markers at the connectivity change points visible on the schematic page. At the same
time, the cursor changes to an exclamation point as shown below, and the status line
warns of net connectivity changes.
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Figure 16 – Connectivity change warning
Because some connectivity changes may not be visible on screen, most
connectivity changes for which you see an alert are documented in the session log.
For more information about connectivity and orthogonal drag, see Capture’s
online help.
Placing buses
A bus is a group of scalar signals (wires). Once the bus acquires a valid name
or alias, then that name or alias defines the signals carried by the bus and connects
those signals to the corresponding nets. For example, the alias A[0:3] defines a foursignal bus that connects the four bus signals to the individual wires named A0, A1,
A2, and A3. Net aliases on wires do not use brackets.
To place a bus
1. From the schematic page editor’s Place menu, choose Bus.
or
Choose the bus tool on the schematic page editor’s tool palette.
2. Click the left mouse button to start the bus.
3. Move the mouse to draw the bus. Click the left mouse button if you want to
place a vertex and change directions, or to connect to another bus as you pass over it.
key while
The bus is constrained to multiples of 90° unless you hold down the
you draw the bus.
4 Double-click to end the bus, then click the Select button on the schematic
page editor’s tool palette.
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5 Highlight the bus and choose Net Alias from the Place menu. Enter an alias
for the bus in the Place Net Alias dialog box that appears, then click OK
6. When you are done placing buses, choose the selection tool or press
dismiss the bus tool.

to

Editing buses
Use the select tool on the schematic page editor’s tool palette to select bus,
then use one of the following methods to open the property editor:
- Choose Properties from the Edit menu
- Choose Edit Properties from the right mouse button pop-up menu Add or
change the bus’s properties on the Schematic Nets tab. These changes can be applied
to the schematic page by clicking Apply or closing the property editor. To make new
properties visible in the schematic page, you must select them in the property editor
and click the Display button and select a display format in the Display Properties
dialog box that appears.
You can also edit the display properties of the text associated with the bus.
Select only the text of the bus, then either choose Properties from the Edit menu, or
choose Edit Properties from the right mouse button pop-up menu. You can also
double-click the text. In the Edit Net Alias dialog box, you can change the Alias,
Color, Rotation, or Font. Click OK to apply changes.
Placing bus entries
Bus entries are used to bring a net into a bus. They are optional. The only
distinction between a bus entry and a wire segment is that two wires that touch are
connected, whereas two bus entries that touch are not connected.
To place a bus entry
1. From the schematic page editor’s Place menu, choose Bus Entry
or
From the schematic page editor’s tool palette, click the bus entry tool.
The bus entry is attached to the pointer.
2. From the Edit menu, choose Rotate to rotate the bus entry 90°
counterclockwise if the bus entry is not at the angle you need.
3. Use the mouse to position one end of the bus entry on the bus, then click the
left mouse button to place the bus entry.
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4. Repeat step 3 until all of the bus entries are placed.
5. Choose the selection tool or press

to dismiss the bus entry tool.

To connect multiple nets to a bus
1. Place a wire to connect the first bus entry to a net.
2. Place an alias on the wire using the lowest value in the bus range. For
example, if you’re using a bus alias of A[0:3], the lowest value in the bus range is
A0.
3. Select the wire, then press
while you drag a copy a specific distance so
that it connects the next net to the bus. The alias value is increased by one.
4. From the Edit menu, choose Repeat. The wire and the incremented alias text
are placed at the specified distance from the previous set.
5. Repeat step 4 for every bus entry in the bus, or repeat steps 3 and 4 as
needed.
6. When you have finished connecting bus entries, press

.

Editing bus entries
To move a bus entry, select it and drag it to a new location.
To rotate a bus entry, select it and choose Rotate from the Edit menu.
Ripping a subset of signals off the bus
You can rip a bus that is a subset of another bus similar to the way you connect
a net to a bus. For example, if you want to rip ADDR[8..15] off of ADDR[0..15],
place a bus entry so that it connects the two buses. Make sure that the name of the bus
being ripped off uses a net alias that is a subset of the second bus. You can route the
ripped bus to any page in the design.
Use hierarchical ports, hierarchical pins, and off-page connectors to connect
the ripped bus to other schematic pages the same way you would with any other bus.
Drawing lines
You use the line tool to draw a single line. The line you draw adopts the
current line style. If you want to draw line with multiple contiguous segments, use the
polyline tool.
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To draw a line segment
1. From the Place menu, choose Line.
or
Choose the line tool on the tool palette.
2. Move the pointer to the line’s beginning.
3. Press and hold the left mouse button while moving the mouse to draw the
line.
4. Release the left mouse button to end the line. The line displays in the
selection color.
5. Choose the selection tool or press

to dismiss the line tool.

To resize a line
Use the selection tool to select a line. Edit handles appear at either end of the
line. With the pointer on one of the two edit handles, press the left mouse button and
drag the line. You can change the angle of the line in the process of resizing it.
Drawing rectangles and squares
You use the rectangle tool to create orthogonal shapes. To create a square, hold
down the
key before you begin drawing. Any rectangles or squares you create
will have the current fill style and line style.
To draw a rectangle or a square
1. From the Place menu, choose Rectangle.
or
Choose the rectangle tool on the tool palette.
2. Move the pointer to one corner of the intended rectangle.
3. Press and hold the left mouse button while you drag the mouse. The
rectangle changes shape as you move the mouse. Release the left mouse button when
you have the correct shape. To draw a square, hold down the
perform this step. The rectangle displays in the selection color.
4. Choose the selection tool or press
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To resize a rectangle or square
Use the selection tool to select a rectangle or square. Edit handles appear on the
four corners. With the pointer on one of the handles, press the mouse and drag the
handle.
Drawing circles and ellipses
You use the ellipse tool to draw a closed ellipse; if you want to draw an arc,
use the arc tool. To draw a circle, hold down the
key while you drag the
mouse. Because they are closed shapes, circles and ellipses will have the current fill
style. They will also have the current line style.
To draw an ellipse or a circle
1. From the Place menu, choose Ellipse.
or
Choose the ellipse tool on the tool palette.
2. Move the pointer to an edge of the intended ellipse.
3. Press and hold the left mouse button while you drag the mouse. The ellipse
changes shape as you move the mouse. If you want to draw a circle, hold down the
key while you perform this step. Release the left mouse button when you have
the correct shape. The ellipse appears in the selection color.
4. Choose the selection tool or press

to dismiss the ellipse tool.

To resize an ellipse or circle
Use the selection tool to select an ellipse or a circle. Edit handles appear on all
four corners of the rectangle that encloses it. With the pointer on one of the handles,
press the mouse and drag the handle.
Drawing arcs
You create an arc of any angle using the arc tool. Because it is a line, an arc
adopts the current line style. If you want to create a full circle, use the ellipse tool.
Drawing an arc is done in three stages:
1. Specify the center of the arc with the first mouse click.
2. Specify the radius of the arc with the second mouse click.
3. Specify the arc segment endpoint with the third mouse click.
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Capture draws the arc counterclockwise from the endpoint, and displays in the
selection color.
To draw an arc
1. From the Place menu, choose Arc.
or
Choose the arc tool on the tool palette.
2. Move the pointer to establish the center of the arc, and press and hold the left
mouse button.
3. Drag the mouse out from the center to establish the radius of the arc, then
click the left mouse button to establish the location of one end of the arc.
4. Use the mouse to establish the other end of the arc and click the left mouse
button. The arc is drawn counterclockwise from the endpoint, and displays in the
selection color.
5. Choose the selection tool or press

to dismiss the arc tool.

To resize an arc
1. Use the selection tool to select an arc. Edit handles appear at the ends of the
arc.
2. With the pointer on one of the handles, press the mouse and drag. The center
remains the same. The other arc endpoint uses the new radius.
Drawing polylines and polygons
To draw a line with multiple contiguous segments, use the polyline tool. The
line you draw adopts the current line style. Polygons can be created with the polyline
tool, and they adopt the current fill style. To create a non-orthogonal polyline, hold
down the

key while you draw.

To draw a polyline
1. From the Place menu, choose Polyline.
or
Choose the polyline tool on the tool palette.
2. Click the left mouse button to begin drawing, click to change directions, and
double-click to end the final segment. To draw non-orthogonal polylines, press
. After you double-click, the polyline displays in the selection color.
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3. Choose the selection tool or press

to dismiss the polyline tool.

To draw a polygon
Follow the instructions above, ending the line with a single mouse-button click
at the beginning point. The polygon adopts the current line and fill style.
To resize a polyline or polygon
Use the selection tool to select a polyline or polygon. Edit handles appear at the
ends of all the lines in the polyline/polygon. With the pointer on a handle, press the
left mouse button and drag the handle.
Adding fill to an object
You can have closed shapes automatically filled in after you finish drawing
them by defining a default fill. From the Options menu, choose Preferences, then
choose the Miscellaneous tab. Click the Fill Style drop-down box to display the
options. Note that you can specify separate options for the schematic page editor and
the part editor. Select one of the options and click OK.
To add fill to an object
1. Select the object
2. From the Edit menu, choose Properties.
3. Select a fill style from the Fill Style drop-down box, then click OK.
Mirroring an object
You can mirror objects horizontally, vertically, or both horizontally and
vertically. Some objects, such as text and bitmaps, cannot be mirrored. If the Mirror
command appears dimmed on the Edit menu, the object cannot be mirrored.
To mirror an object
1. Select the object.
2. From the Edit menu, choose Mirror, then choose Mirror Horizontally, Mirror
Vertically or Both. The object flips in the chosen direction.
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Rotating an object
You can rotate objects by 90° increments. Some objects, such as bitmaps,
cannot be rotated. If the Rotate command appears dimmed on the Edit menu, the
object cannot be rotated.
To rotate an object
1. Select the object.
2. From the Edit menu, choose Rotate. The selection rotates 90°
counterclockwise.
Moving an object
1. Move the mouse anywhere over the object, except over resize handles.
2. Press the left mouse button, without releasing it, and drag the object until it
is where you want it.
3. Release the mouse button.
Cutting an object
Select the object. From the Edit menu, choose Cut. The object is removed from
the schematic page and placed on the Clipboard.
Copying an object
There are two ways to copy an object:
1 Select the object. From the Edit menu, choose Copy.
The object remains on the schematic page and a copy of it is placed on the
Clipboard. It can be pasted in Capture or in other Windows programs.
or
Position the pointer on the object. Press the left mouse button, hold down the
key, and drag a copy of the object to the new location.
Pasting an object
To use the Paste command, an object must already be on the Clipboard via the
Cut or Copy command. Place the pointer where you want the object to be pasted.
From the Edit menu, choose Paste. The object is placed on the schematic page.
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Deleting a selected object
There are several ways to delete a selected object:
- From the Edit menu, choose Delete.
- From the right mouse button’s pop-up menu, choose Delete.
- Press
- Press

.
.

Placing a bitmap
You can create a bitmap in another application and place it on a schematic
page, on a library part, or in a custom title block.
To place a bitmap
1. From the Place menu, choose Picture. A standard Open dialog box appears.
2. Select the bitmap file. If the file is not listed in the File name text box:
a) In the Look in drop-down list, select a new drive.
b) Choose the Up One Level button.
c) In the Files of type box, select the type of file you want to open.
3. Click OK. A rectangle representing the bitmap image is attached to the
pointer.
4. Click the left mouse button to place the bitmap at the desired location. If you
want to place multiple copies of the bitmap, repeat this step.
5. Press

or choose the selection tool.

To resize a bitmap
1. Select the bitmap so that it displays in the selection color with edit handles at
the four corners.
2. Position the pointer over an edit handle and drag the edit handle. The
bitmap’s size and shape change to accommodate the new dimensions. Using the
key constrains resizing the bitmap to proportional changes in the horizontal
and vertical directions.
Placing text
You can place text, in the font of your choice, on a schematic page or on a part
to document your schematic page.
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To place text on a schematic page
1. From the Place menu, choose Text.
or
Choose the text tool on the tool palette.
2. Enter the text. To type numbers using the numeric keypad on your keyboard,
you must first enable the
key.
3. Complete the dialog box selections by specifying font, color, and rotation.
4. Click OK to close the dialog box. A rectangle representing the text is
attached to the pointer.
5. Click the left mouse button to place the text at the desired location. You can
place multiple copies of the text by clicking the left mouse button at each location
where you would like text.
6. When you are done placing text, choose End Mode from the right mouse
button pop-up menu or press

.

To move text
1. Select the text so that it displays in the selection color with edit handles at
the four corners.
2. Position the pointer over the text – not an edit handle – and drag the text to
the new location.
3. Release the mouse button to place the text.
4. Click an area where there are no parts or objects to deselect the text.
To move or copy text using the Clipboard
1. Select the text.
2. From the Edit menu, choose Cut. The text is placed on the Clipboard.
or
From the Edit menu, choose Copy. A copy of the text is placed on the
Clipboard.
3. From the Edit menu, choose Paste. The text is attached to the pointer.
4. Move the pointer to the location where you want to place the text and click
the left mouse button. The text is placed and displays in the selection color.
5. Click an area where there are no parts or objects to deselect the text.
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To rotate text
1. Select the text so that it displays in the selection color with edit handles at
the four corners.
2. From the Edit menu, choose Rotate. The text rotates 90° counterclockwise.
3. Repeat step 2 as necessary.
4. Click an area where there are no parts or objects to deselect the text.
The text bounding box
Text that you place wraps according to the dimensions of its bounding box.
To change how the text wraps
1. Select the text so that it displays in the selection color with edit handles at
the four corners.
2. Position the pointer over an edit handle and drag the edit handle. The text
inside the bounding box rewraps within the new dimensions.
Deleting text
To delete the text and its bounding box, select the text so that it displays in the
selection color with edit handles at the four corners. Press either the

key or the

key.
To delete text when it is highlighted in the Edit Text dialog box, press the
key, the
key, or begin typing new text.
To delete individual words within the text, double-click the text, or select the
text and choose Properties from the Edit menu. The Edit Text dialog box appears,
with the text highlighted. Press one of the four arrow keys to remove the text
highlighting. Double-click the word you want to remove. Press the

key or the

key.
Modifying text
To add more text to text you have already placed, double-click the text, or
select the text and choose Properties from the Edit menu. The Edit Text dialog box
appears, with the text highlighted. Press one of the four arrow keys to remove the text
highlighting. Type the additional text. When you are done, click OK.
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Finding text
You can use the Find command to search for text in an entire project, in
selected schematic pages, on one schematic page, or in the part editor.
To find text
1. In the project manager, select the root schematic folder (to search the entire
project) or select specific schematic pages.
or
Make the schematic page editor or the part editor the active window.
2. From the Edit menu, choose Find. The Find dialog box appears.
3. Leave the asterisk in the Find What text box to locate all occurrences of all
text.
or
Narrow the text search by entering specific text in the Find What text box.
4. Verify that the Match Case option is as you want it.
5. Select Text from the object types in the Scope area.
6. Click OK.
If you search the entire project or selected schematic pages from the project
manager, the search results are listed in the browse window. If you search with either
the schematic page editor window or the part editor window as the active window,
the results of the search display in the selection color in either the schematic page
editor window or the part editor window.
Replacing text
Schematic page editor or part editor text can be replaced by entering the
replacement text from the keyboard, or copying the replacement text from another
application.
To replace text
1. Select the text so that it displays in the selection color with edit handles at
the four corners.
2. From the Edit menu, choose Properties. The Edit Text dialog box appears,
with the text highlighted.
3. Enter the replacement text, then click OK.
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Importing text
You can import text from any Windows program that copies text to the
Clipboard.
To import text from other Windows applications
1. In the other Windows application, copy the text to the Clipboard using that
program’s Copy command.
2. Make the schematic page editor or part editor the active window.
3. From the Place menu, choose Text. The Place Text dialog box appears.
to paste the text into the text box, then verify that the color,
4. Press
font, and rotation are as you want them and click OK. A rectangle representing the
text is attached to the pointer.
5 Click the left mouse button to place the text at the desired location.
6. When you are done placing text, press

or choose the selection tool.

Exporting text
You can export Capture text to any Windows program that uses the Clipboard.
You must select the text within the Edit Text or Place Text dialog boxes. Otherwise,
copying a text object treats the text as a graphic.
To export text to other Windows applications
1. In Capture, double-click the text you want to export. Capture displays the
Edit Text dialog box.
2. Select the text.
3. From the Edit menu, choose Cut or Copy. The text is placed on the
Clipboard.
4. Activate the other Windows application and use that application’s Paste
command to place the text.
Character formatting
You may want the text to have a distinctive appearance, or to fit within a
specific space. Capture supports TrueType fonts. You can preview a sample of the
selected font before you choose it. You can also select the default font that you set up
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in the Fonts tab in either the Design Template dialog box or the Design Properties
dialog box (available from the Options menu).
To change fonts and point sizes
1. If you are placing the text, choose Text from the Place menu. The Place Text
dialog box appears.
or
If the text has already been placed, double-click the text. The Edit Text dialog
box appears.
2. In the Font group box, click the Change button. The Font dialog box
appears.
3. Select a font, style, and size. Sample text displays in the Sample group box.
4. Click OK twice.
Printing and plotting
To send output to a printer, a plotter, or an encapsulated PostScript file, use the
standard Windows Print Setup, Print Preview, and Print dialog boxes.
Printing commands can be chosen from the File menu in the project manager,
the schematic page editor, or the part editor. You can print schematic pages, parts, or
packages.
To configure a printer or plotter
From the File menu, choose the Print Setup command. Select an appropriate
printer or plotter, or change the printer settings if necessary, and then click OK.
Printing or plotting schematic pages
You can print or plot a schematic page, or several schematic pages, from the
project manager.
To print or plot a schematic page or pages
1. Activate the schematic page editor window for the page you want to print.
or
In the project manager, select the schematic page or pages.
or
If you want to print all the pages in the design, select the design name in the
project manager.
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2. From the File menu, choose Print. The Print dialog box appears.
3. Select the scale, print offsets, print quality, number of copies, and whether to
print to file.
4. Click OK to send the image to the output device.
Printing or plotting parts or packages
With the part editor active and open to a specific part or package, you can
create a print or a plot of that part or package. You can also print a library part from
the project manager.
To print or plot a part or package
1. Select the part or package you want to print in the schematic page editor.
or
Select the library part in the project manager.
2. Click the right mouse button in the project manager, and choose Edit Part
from the pop-up menu. The part appears in the part editor.
3. From the part editor’s View menu, choose Part to print a part or choose
Package to print a package.
4. From the File menu, choose Print. The Print dialog box appears.
5. Select the scale, the print quality, and the number of copies.
6. Click OK to send the image to the output device.
Printing the session log and text editor windows
With the text editor window or session log active, you can print the contents of
the window.
To print a text editor window
1. Make the text editor the active window.
2. From the File menu, choose Print. The Print Range Selection dialog box
appears.
3. Select whether to print highlighted text or the entire file.
4. Click OK to send the text to the output device.
To print the session log
1. Make the session log the active window.
2. From the File menu, choose Print. The Print dialog box appears.
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3. Click OK to send the text to the output device.
Previewing printer or plotter output
Using the Print Preview command, you can preview your schematic page, part,
or package output to check its appearance before you commit it to paper.
To preview a schematic page
1. From the File menu, choose Print Preview. The Print Preview dialog box
appears.
2. Specify appropriate values in the dialog box, and then click OK. The Print
Preview display window opens with a display of your schematic page, part, or
package.
3. Use the Previous page and Next page buttons to view other pages you intend
to print.
4. To zoom in, move the magnifier pointer to a specific area and click the left
mouse button.
5. Choose the Close button to close the Print Preview window.
Or
1 Choose the Print button to send the page or pages to the output device, using
the defaults set in the Print Setup dialog box.
Scaling printer or plotter output
You can manually scale, or have Capture automatically scale, printer output
and plots to fit a given paper size.
To scale a print or a plot
1. From the File menu, choose Print. The Print dialog box appears.
2. Select one of the three options in the Scale box.
-The Scale to paper size option scales each schematic page to fit a single sheet
of paper (as configured in the printer driver).
-The Scale to page size option scales each schematic page to the sheet size you
select in the Page size area. The sheet size is configured in the Page Size tab in the
Design Template dialog box.
-The Scaling option scales your schematic page to a factor between 0.100 and
10.000.
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3. If you select the Scale to page size option in step 2, the Page size area
becomes available. Select a sheet size.
This results in multiple sheets of paper if you select a sheet size larger than
your printer paper.
4. Click OK to print the image.
Special considerations for plotting
Vector (pen) plotters do not support bitmaps directly. If you are sending
Capture output to such a plotter, it will not plot your bitmaps. Most inkjet and thermal
plotters will plot bitmaps.
Plotter pen colors
The plotter driver maps your color choice to the closest available pen color as
established in your plotter driver configuration. See your plotter’s driver setup and
documentation for more details.
Many plotters do not have drivers that ship with Windows. If you do not see
the plotter you are looking for in the list of available drivers, contact your plotter
manufacturer and ask for a Windows driver. If your plotter emulates HPGL, use the
HPGL driver as an alternative solution.
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3 LABORATORY WORKS
3.1 LABORATORY WORKS №1
DRAWING OF TACTIC IMPULSES GENERATOR SCHEME
The principal scheme may be done in two ways:
- all necessary scheme elements are connected directly to input and output of
micro-schemes;
- all necessary scheme elements are connected to input and output of microschemes through the bas bar.
To draw the principle scheme of micro-processing system generator by the first
variant the micro -scheme INTEL 8284 is used which may be found in INTEL
library.
To do this it is necessary to carry out the following actions:
- to clic for dialogue box PLACE PART;
- to search for INTEL library and find 8284 scheme and input it on the
monitor. After that the next element should be connected directly to micro-scheme
generator inputs:
a) quarts resonator (found in DIVICE library named CRISTAL) together with
the capacitor C1 to inputs X1,X2(figure 16,a)
b) generator setting scheme at initial state to RES input (R1,C2- the element,
which provides automatic signal formation when electric power is switched on)
(figure 16,b)
c) connecting slep to input RDY1 (figure 16,c)
d) voltage of 5W to input AEN2 and ground to inputs AEN1, F/C.
All elements mentioned above searched in DEVICE library should be
connected between each other and micro-scheme inputs.
To draw the generator INTEL 8284 principal scheme by second variant it is
necessary to connect the same element to micro-schemes outputs by means of
connecting bas bar. The bas bar is the vertical straight line which the connecting lines
from each element are connected. The numbering of the input connecting lines is
done in top-down direction and the numbering of the output connecting lines which
run out of bas bar are connected to generator INTEL 8284 inputs and are correlated
with the numbers of communication lines schemes.
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a)

b)

c)

Figure 16
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3.2 LABORATORY WORK №2
DRAWING OF TYPICAL POWER BLOCK

Typical power block for electronic equipment with micro-scheme TTL/KMOP
type and input stabilized voltage of +5V has downing transformer changing voltage
to bridge D1…D4. The voltage of transformer is approximately 12V. Alternative
direct voltage at the capacitor output is being going to the stabilizer LM2931T-5.0
9(see library ANALOG 1).The voltage from stabilizer is directed to the output of the
scheme. C1, C2 capacitors are set up at the input and output of stabilizer. Scheme at
figure 17 has be done by computer.

Figure 17

56

Engineering graphics “OrCAD Capture”

3.3 LABORATORY WORK № 3
DRAWING OF Analog Custom Unit.
BORSCHT TUCTIONS
An analogue phone accesses an analogue customer unit (ACU) via 2-wire
analogue subscriber line (SL). ACU converts analogue informational signal to digital
and vice versa. The customer unit has 4-wire output toward a Digital Switching
Network (DSN) [6].
ACU supports the terminals listed below:
– phones with pulse dialing;
– phones with DTMF dialing;
– payphones for local and tall communications;
– modems.
The circuit of ACU contains individual part for a subscriber and a shared part
based on a programmable logical array (PLA). Controller of a subscriber module
controls ACU operation with the help of the PLA.
An analogue customer unit performs the BORSCHT functions listed below.
BORSCHT abbreviature refers to the set of functions performed by an analogue
customer unit of a Digital Switching System. These functions are listed below.
Battery feed.
This function ensures power supply for a subscriber terminal. Power supply
bridge includes a power source (wire a) and electric choke (wire b). The power
source includes VT-1 and VT-2 transistors as well as R1, R2, R4 and R5 resistors.
The electric choke includes VT-3, VT-4 transistors as well as R6, R7, R8, R9
resistors and C1 capacitor.
Overvoltage protection function prevents a subscriber terminal or an
analogue customer unit from being damaged by high voltage or current values. The
function is provided by RV-1, RV-2 posistors and VD-1, VD-2 stabilizer diodes.
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Resistance of RV-1, RV-2 increases according to current value increase. Resistance
of VD-1 and VD-2 drives down if voltage at the wires increases.
Ringing function allows to inform a subscriber about an incoming call. A
ringing generator provides this function. The ringing generator accesses the
subscriber line via contacts of the K-2 relay. Therefore, the K-2 relay connects
subscriber line to the ring generator circuit. Ring generator circuit includes electric
switch and VU-3 optron. It senses answer of subscriber B. Optical resistor VU-2
provides 1 to 4 ringing periodicity.
Subscriber line (SL) supervision function enables control of a subscriber line
state. With the help of this function the controller senses on-hook and off-hook states
of the subscriber line. The SL supervision function is provided by the scan point
based on the VU-1 optron. It lights up if subscriber loop is closed and goes out if the
loop is broken. It flashes during pulse dialing.
Coding function enables analog to digital (A/D) and digital to analog (D/A)
conversions of voice-band signals. The coding-filtering unit performs the coding
function. Transmission part of this unit includes an operational amplifier, band-pass
filter (0.3-3.4 kHz), A/D converter and buffer register. Receiving part is made up of a
buffer register, D/A converter, low-pass filter, and operational amplifier.
Hybrid function refers to the transition from 2-wire input (of subscriber line) to
4-wire output (towards DSN). This function is provided by hybrid system.
Testing function allows to test both a subscriber line and a part of analogue
customer unit. This function is performed a by testing unit. The testing unit uses
contacts of the K-1, K-2 and K-3 relays to connect either to SL or to the ACU.
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3.4 LABORATORY WORK №4
DRAWING OF “KVANT” SET
“KVANT” set is designed for powering telephone microphones of automatic
telephone station (ATS). The set consists of: diodes, resistors, transistors,
electromechanic реле ,etc. All these components could be found in DEVICE library.
Scheme at figure 18 has be done by computer.

Figure 19
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3.5 LABORATORY WORK №5
DRAWING OF MEMORY COMPONENTS
Any complex digital system such as EOM type consists of inside memory
components which in reality are micro-schemes.
The digital memory micro-scheme is presented as a table, where each line
represents words 1 Bite long. All the lines of the table are numbered. Each number
corresponds to the words address any word could be read – written in a separate cell.
The bases of 3Y micro-schemes are elementary cells named triggers and have two
states. Trigger keeps and gives 1 Bite only. For keeping or giving one word 8 triggers
are needed. Digital memory micro-scheme of 8 Bite capasitor is given in the table of
figure 19. Besides address inputs A0…An and inputs/outputs D0…D7 there are
supplementary inputs CSW/R etc, thanks to which the choice of MS and the type of
work are done.
Table 4
Address
A0
A1
A2
0
0
0
0
0
1
0
1
0
0
1
1
1
0
0
1
0
1
1
1
0
1
1
1

D7
1
0
1
0
1
0
1
0

D6
0
0
1
1
1
1
0
0

D5
1
0
1
0
0
1
1
0

Bit position
D4
D3
0
0
1
1
0
1
0
1
0
0
0
0
1
0
0
1

D2
1
0
0
0
0
0
1
1

D1
1
0
1
1
0
1
0
0

D0
0
1
0
0
1
0
0
0

According to the type of information recording and the reading memory
equipment is devided into Random Access Memory (RAM) and Ready Only Memory
(ROM). Current renewed data are kept in RAM that corresponds to both former
information recording and reading. The information is kept in ROM only, which is
used exceptly for reading.
Graphical memory micro-schemes presentations are found in a Place Part
dialogue display command in memory catalogue.
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3.6 LABORATORY WORK №6
THE SETTING OF MICRO-SCHEMES LIBRARY
The micro-schemes library is completed on the bases of the materials
mentioned in Part 2. The micro-schemes that should appear on the monitor are
depicted at figure 20.

a)

b)
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c)

d)

e)

f)
Figure 21
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3.7 LABORATORY WORK №7
DRAWING OF CLOCK-PULSE GENERATOR THAT FROMS
PULSE SEQUENCE OF FREQUENCY FOR ALL MPS
Signal forming of synchronization and (RST) offloading is made by clockpulse generator scheme showed on Figure 22. MC88916 of Motorola Company is
used in this microscheme. Crystal resonator Y1 is used to regulate frequency. I/O
generator connection to CPU is completed according to the name of outputs, lines
with the same names are linked. Signal of clock frequency is delivered on CPU and
other scheme devices.
For drowing this sheme you must used microscheme MC88916 from
laboratory work №6 (Figure 21, f).

Figure 22
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4 LABORATORY TASK CONTENT
The laboratory work in drawing of principal electric schemes in OrCad
programme includes three practical lessons 2 hours each.
4.1 Principal electric schemes tactic Impulses generator with INTEL microscheme usage of INTEL 8086 micro-processing system.
4.2 Principal schemes of power standard block.
4.3 Principal schemes of an output line set of quazy electronic automatic
telephone station “Kvant”.
4.4Principal memory schemes of a micro-processing scheme.
4.5To organize micro-scheme memory library by drawing micro-schemes
accoding to Ukranian standards and teaching demands.

5 KEY PROBLEMS
5.1 What is the order of input the principal schemes OrCad Capture drawing
programmes?
5.2 What are the tool palette used for?
5.3 What kind of library keeps such components as transformer and diods?
5.4 What kind of library keeps such components as INTEL company microschemes?
5.5 What is the order of numbering connecting wires entering the bas bar?

6 HOME TASK
6.1 Learn the main principals of work in Programme set OrCad Capture (see
“Key outlines” at manual).
6.2 Master drawing skills of electronic scheme communication system (see
“Key outlines”).
6.3 Look through the work principals of new library setting (see “Key outlines”
at manual).
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